2011-04-20

Readings on Information Technology []

Moved to the page http://3rdstage.wikia.com/wiki/Readings_on_Information_Technology in my wiki as of 20th Jul. 2012.

Computer Science/Programming

Tree

Java SE

Reflection
Generic
Concurrency
Caching

Java EE

Spring

AOP

Testing Frameworks

Logging Frameworks

Templating Frameworks

FreeMarker

HTML

Named Entity

CSS

JavaScript

jQuery
jQuery Plugins
Raphael

XML

RELAX NG

JSON

Database

Sybase
Informix
HyperSQL (HSQLDB)

SQL

Version Control

Version control policies sample

Wiki

Textile

UNIX, Linux

Shell
AIX
AIX Commands
  • oslevel
    Reports the latest installed level (technology level, maintenance level and service pack) of the system.
  • lsdev
    Displays devices in the system and their characteristics.
  • prtconf
    Displays system configuration information.
  • lparstat
    Reports logical partition (LPAR) related information and statistics.
  • no
    Manages network tuning parameters.

Software Testing

Code Analysis
Splint
  • Flags of Splint
  • Win32 Installation of Splint
  • Re: About splint in Windows
  • Exact condition to exclude header file
    The standard behavior of Splint on encountering #include <X.h> is to search for a file named X .h on the include search path (set using –I) and then the system base include path (read from the include environment variable if set or using a default value, usually /usr/include). If X .h is the name of a header file in a loaded standard library and X .h is found in a directory that is a system directory (as set by the -sysdirs flag; the default is /usr/include), X .h will not be included if +skip-iso-headers or +skip-posix-headers (depending on whether X .h is an ISO or POSIX header file) is on (both are on by default). To force all headers to be included normally, use ‑skip-iso-headers.

0 comments:

Post a Comment